Нужна с задачей! Буду рад за !
Задачу надо решить с С++.
12.141. Дан двумерный массив. Составить программу:
а) которая определяет, является ли последовательность элементов некоторой строки массива упорядоченной по неубыванию;
б) которая определяет, является ли последовательность элементов некоторого столбца массива упорядоченной по невозрастанию.
В случае отрицательного ответа в обеих задачах должны быть напечатаны
координаты первого элемента, нарушающего указанную упорядоченность.
Код:
#include <iostream>
#include <string>
using namespace std;
void printArray(int** arr, size_t X, size_t Y) {
for (size_t i = 0; i < X; ++i) {
for (size_t j = 0; j < Y; ++j) {
cout << arr[i][j] << " ";
}
cout << endl;
}
}
int main() {
size_t X, Y;
cout << "Number of rows in the array: ";
cin >> X;
cout << "Elements in each row of the array: ";
cin >> Y;
int** arr = new int* [X];
for (size_t i = 0; i < X; ++i) {
arr[i] = new int[Y];
cout << "#" << i + 1 << ": ";
for (size_t j = 0; j < Y; ++j)
cin >> arr[i][j];
}
size_t index;
cout << "index to check the row for non-decreasing ordering: ";
cin >> index;
--index; // numbering from 1
bool flag = 1;
for (int i = 0; i < Y - 1; ++i) {
if (!(arr[index][i] <= arr[index][i + 1])) {
cout << "No, " << i + 1 << (i + 1 == 1 ? "st" : (i + 1 == 2 ? "nd" : (i + 1 == 3) ? "rd" : "th")) << " element (" << arr[index][i] << ") violates the non-decreasing ordering (" << arr[index][i] << " > " << arr[index][i + 1] << ").\n";
flag = 0;
break;
}
}
if (flag)
cout << "Yes, the specified row is ordered in non-decreasing order.\n";
flag = 1;
index = 1;
cout << "index to check the column for non-increasing ordering: ";
cin >> index;
--index;
flag = 1;
for (int i = 0; i < X - 1; ++i) {
if (!(arr[i][index] >= arr[i + 1][index])) {
cout << "No, " << i + 1 << (i + 1 == 1 ? "st" : (i + 1 == 2 ? "nd" : (i + 1 == 3) ? "rd" : "th")) << " element (" << arr[i][index] << ") violates the non-increasing ordering (" << arr[i][index] << " < " << arr[i][index + 1] << ").\n";
flag = 0;
break;
}
}
if (flag)
cout << "Yes, the specified row is ordered in non-increasing order.\n";
}