В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
79873299489
79873299489
15.04.2023 08:36 •  Информатика

Нужна : составить программу по которой компьютер угадает число введеное с клавиатуры (с repeat), с пояснениями (игра похожа на игру угадай число, но угадывает компьютер, а мы задумываем)

Показать ответ
Ответ:
лиза2698
лиза2698
25.05.2020 23:17

var x,y,a:integer;
c:boolean;
begin
readln(x); {считываем}

a:=1;
repeat

writeln(a,' попытка выбор компьютера пал на - ');
y:=random(x)+1; {задаем промежуток рандомом}

write(y);
if x=y {сравниваем} then c:=true; {выходим из цикла в случае успеха}
until c; {если с=true тогда выход из цикла, иначе крутимся дальше}

writeln('Компьютер сделал ',a,' попыток.');
end.


Более доработанная и понятная, если возникают какие-то вопросы - пиши в личку.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота