В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

НУЖНА Составить программу вычисления функции через два оператора(отдельно программу с While и отдельно программу с for). Найти все двузначные числа, в которых есть заданная цифра


НУЖНА Составить программу вычисления функции через два оператора(отдельно программ

Показать ответ
Ответ:
artem222529ozd6op
artem222529ozd6op
10.04.2023 09:26

Неверный код:

program n9;

var v2,v3,v4,v5,i,st: integer;

m: array[1..20] of integer;

begin

st:= 20;

writeln('Количество учеников: ',st);

for i:= 1 to 20 do

begin

write('Введите оценку ',i,' ученика: ');

readln(m[i]);

if m[i] == 2 then v2:= v2 + m[i];

if m[i] == 3 then v3:= v3 + m[i];

if m[i] == 4 then v4:= v4 + m[i];

if m[i] == 5 then v5:= v5 + m[i];

end;

end.

Верный код:

program n9;

var v2,v3,v4,v5,i, КОЛИЧЕСТВО УЧЕНИКОВ В ЦИФРАХ integer;

m: array[1..20] of integer;

begin

st:= 20;

writeln

for i:= 1 to 20 do

begin

write

readln(m[ОЦЕНКА УЧЕНИКА В ЦИФРАХ]);

if m[ОЦЕНКА УЧЕНИКА В ЦИФРАХ] == 2 then v2:= v2 + m[ОЦЕНКА УЧЕНИКА В ЦИФРАХ];

if m[ОЦЕНКА УЧЕНИКА В ЦИФРАХ] == 3 then v3:= v3 + m[ОЦЕНКА УЧЕНИКА В ЦИФРАХ];

if m[ОЦЕНКА УЧЕНИКА В ЦИФРАХ] == 4 then v4:= v4 + m[ОЦЕНКА УЧЕНИКА В ЦИФРАХ];

if m[ОЦЕНКА УЧЕНИКА В ЦИФРАХ] == 5 then v5:= v5 + m[ОЦЕНКА УЧЕНИКА В ЦИФРАХ];

end;

end.

0,0(0 оценок)
Ответ:
kitti31
kitti31
05.03.2022 22:20

Построение сетей беспроводной передачи данных Wi-Fi (IEEE 802.11) в настоящее время получило широкое распространение за счет массы преимуществ. Среди основных достоинств данной технологии можно выделить следующее:

Не потребуется проектировать ЛВС (СКС), прокладывать провода, монтировать короба под них, а это в свою очередь обеспечивает минимальные сроки на построение компьютерной сети в офисе или производственном помещении. Это очень ценное качество для небольших офисов и временных мероприятий, когда требуется быстро развернуть, а потом, также быстро демонтировать компьютерную сеть. Монтаж беспроводной сети Wi-Fi в офисе или других помещениях возможен без остановки рабочего процесса вашей компании, т.к. монтаж сведён к минимуму.

- Отсутствие проводов.

Не всегда возможно проложить кабель до того или иного сетевого устройства, а иногда прокладка такой кабельный трассы может оказаться очень дорогой и потребовать много времени, а иногда потребовать согласования. Гораздо проще и значительно дешевле использовать беспроводные технологии передачи данных по радиоканалу (wireless, wlan), которые не требуют прокладки кабеля.

- Минимум строительно-монтажных работ.

Внешний вид вашего помещения и его отделка не претерпят никаких заметных видимых изменений при организации беспроводной сети Wi-Fi — строительно-монтажные работы практически не потребуются и сведены к минимуму, т.к. тянуть провода и разводить розетки не понадобится;

- Высокая скорость.

Беспроводная сеть Wi-Fi сегодня может обеспечить скорости до 108 Мбит/с, что соответствует обычной проводной локальной сети (ЛВС), которые мы привыкли видеть в каждом обычном офисе, этой скорости вполне хватает для большинства офисных приложений и для работы с базами данных.

- Дешевизна установки и владения.

Всё что требуется для работы Wi-Fi сети это точка доступа (access point), которых может быть одна или несколько десятков в зависимости от топологии помещений и используемого в вашей компании программного обеспечения.

- Гибкость в построении.

Беспроводную сеть можно построить там, где нельзя или не выгодно прокладывать кабели. Технология Wi-Fi облегчает постоянную или временную установку сети и ее перемещение при необходимости, обеспечивает возможность быстро организовывать временные сети для гостей либо на время проведения мероприятий.

- Высокая мобильность рабочего места.

Можно свободно перемещать рабочие места сотрудников по своему усмотрению и производственной необходимости в пределах зоны покрытия беспроводной сети, т.к. нет жесткой привязки рабочих мест к информационной розетке и нет ограничений накладываемых длинной проводов, мобильность персонала, возможность всегда быть на связи, соблюдение принципа «anyone, anywhere, anytime».

- Реконфигурация и масштабируемость.

Расширение беспроводной сети Wi-Fi не является простой задачей: пользовательские устройства можно легко интегрировать в сеть, установив на них беспроводные сетевые адаптеры, сегодня большое кол-во устройств (PDA - наладонники, смартфоны, ноутбуки и обычные компьютеры) оснащается беспроводными сетевыми адаптерами на стадии его производства самими производителями. Wi-Fi сети дают возможность быстро добавлять, перемещать и изменять права пользователей, новых направлений, каналов связи и рабочих мест. Интеграция Wi-Fi сети с проводной сетью – якорная ссылка.

- Совместимость.

Различные марки и типы совместимых клиентских и сетевых устройств будут взаимодействовать между собой. К сети могут подключаться любые мобильные устройства поддерживающие Wi-Fi с учётом установленных  сетевых протоколов безопасности. Увеличение производительности Повышение производительности организации, использующей сети Wi-Fi достигается за счет более эффективного использования рабочей силы, а так же офисного пространства, и даёт возможность работать сотрудникам там, где они нужны, а не только за офисным столом.

- Деловая репутация.

Использование беспроводных сетей Wi-Fi демонстрирует желание развиваться в ногу со временем и демонстрирует активную политику и осведомлённость в сфере IT-технологий.

Недостатки Wi-Fi:

1.           Относительно высокая стоимость оборудования

2.           Скорость доступа зависит от среды передачи

3.           Хотя технология на сегодняшний день позволяет достичь скоростей до 108мб/c, что сравнимо со скоростью кабельных сетей, скорость напрямую зависит от среды передачи сигнала.

Для улучшения качества сигнала возможно использование внешних дополнительных антенн: узконаправленной для соединения в зоне прямой видимости, либо когда необходимо чтобы сигнал распространялся в одном направлении и всенаправленной, когда необходимо увеличить зону покрытия в помещении.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота