Нужна Требовалось написать программу, при выполнении которой с клавиатуры считывается натуральное число N, не превосходящее 109, и выводится минимальная цифра этого числа. Программист торопился и написал программу неправильно.
var N: longint;
digit, min_digit: integer;
begin
readln(N);
min_digit := 9;
while N >= 10 do
begin
digit := N mod 10;
if digit < min_digit then
min_digit := digit;
N := N div 10;
end;
writeln(digit);
end.
Последовательно выполните следующее.
1.Напишите, что выведет эта программа при вводе числа 547.
2.Найдите все ошибки в этой программе (их может быть одна или несколько). Для каждой ошибки:
1) выпишите строку, в которой сделана ошибка;
2) укажите, как исправить ошибку, – приведите правильный вариант строки.
Обратите внимание, что требуется найти ошибки в имеющейся программе, а не написать свою, возможно, использующую другой алгоритм решения. Исправление ошибки должно затрагивать только строку, в которой находится ошибка.
1 программа:
var x, y, t:integer;
begin
for x:=3 to 15 do begin
writeln('x = ', x);
t := x - 2;
y := 7*t*3-6*t+10;
writeln('y = ', y);
writeln('');
end;
end.
2 программа:
const pass ='45xlua';
var x:string;
a:boolean;
begin
a:= false;
while a<>true do begin
writeln('Введите пароль');
readln(x);
if x = pass then begin
a:=true;
writeln('Пароль верный');
end
else
writeln('Пароль неверный, введите еще раз');
writeln('');
end;
end.
4 программа:
var a, a1, a2, x, kol:integer;
begin
writeln('Введите четырёхзначное число');
readln(a);
x := a;
while x<>0 do begin
x:= x div 10;
kol:= kol + 1;
end;
if (kol = 4) then begin
a1 := a div 100;
a2:= a mod 100;
writeln(a1+a2);
end
else
writeln('Число не является четырёхзначным');
end.
В 1957 году Министерство обороны США посчитало, что на случай войны Америке нужна надёжная система передачи информации. Агентство передовых оборонных исследовательских проектов США (DARPA) предложило разработать для этого компьютерную сеть. Разработка такой сети была поручена Калифорнийскому университету в Лос-Анджелесе, Стэнфордскому исследовательскому центру, Университету Юты и Университету штата Калифорния в Санта-Барбаре. Компьютерная сеть была названа ARPANET (англ. Advanced Research Projects Agency Network), и в 1969 году в рамках проекта сеть объединила четыре указанных научных учреждения. Все работы финансировались Министерством обороны США. Затем сеть ARPANET начала активно расти и развиваться, её начали использовать учёные из разных областей науки.
Объяснение: