В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Тимур2020
Тимур2020
06.05.2020 10:13 •  Информатика

нужна ваша решение на языке паскаль

На обработку поступает натуральное число, не превышающее 10^9. Нужно написать программу, которая выводит на экран сумму нечетных цифр числа, которые делятся на 3. Если в числе нет таких цифр, требуется на экран вывести «NO».

Показать ответ
Ответ:
Dashka2005Dashka2005
Dashka2005Dashka2005
14.10.2020 05:52

program z1;

var a,s: longint;

begin

write ('Введите число: ');

readln(a);

s:=0;

repeat

if (a mod 10 mod 2 = 1) and (a mod 10 mod 3 = 0) then s:=s+a mod 10;

a:=a div 10

until a=0;

if s = 0 then write('NO')

else writeln(s)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота