В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
alena667
alena667
11.02.2020 23:25 •  Информатика

Нужно было написать программу, которая находит наибольшее из трех чисел a, b и c. Начинающий программист написал фрагмент программы так: if a > b then
M := a
else
M := b;
if c > b then
M := c
else
M := b;
При каких наборах значений a, b, c эта программа работает неверно?
Выберите все подходящие варианты.

a = 1; b = 4; c = 7
a = 1; b = 7; c = 4
a = 7; b = 4; c = 1
a = 4; b = 7; c = 1
a = 7; b = 1; c = 4
a = 4; b = 1; c = 7

ОТВЕТ ДАЙТЕ ПРАВИЛЬНЫЙ НЕ ОТ БАЛДЫ

Показать ответ
Ответ:
harweybeaks
harweybeaks
14.03.2021 19:53

a = 1; b = 4; c = 7

a = 1; b = 7; c = 4

a = 4; b = 7; c = 1

a = 4; b = 1; c = 7

Объяснение:

Вот код программы на C++:

#include <iostream>

using namespace std;

void main()

{

setlocale (LC_ALL, "RUS");

int a, b, c, M;

cout << "Введите число а: ";

cin >> a;

cout << "Введите число b: ";

cin >> b;

cout << "Введите число c: ";

cin >> c;

if (a > b)

{

 M = a;

}

else

{

 M = b;

}

if (c > b)

{

 M = c;

}

else

{

 M = b;

}

cout << "Наибольшее число: " << M << endl;

}

Можешь сам(а) на онлайн-компиляторе проверить выражения, если не уверен(а).

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота