В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
chelsi09
chelsi09
01.05.2022 03:44 •  Информатика

Нужно написать программу, которая будет хранить информацию о рейтинге фильмов. Для одного фильма может быть от нуля и более рейтингов. Каждый рейтинг содержит информацию об имени пользователя и его оценку от 0 до 10 Базовые данные для программы:

movies = {
"Django Unchained": {
"John": 10,
"Jack": 9
},

"Spider-Man": {}
}

Программа должна уметь:
Добавлять фильм:
пользователь вводит название, например "Interstellar", если его нет в списке фильмов, то программа выводит сообщение об успешном добавлении фильма:
"Movie added successfully"
если фильм уже есть, то вывести: “This movie already exist!”
Добавлять рейтинг к фильму
Пользователь вводит название, например "Interstellar"
Если фильм не существует, вывести сообщение
"This movie doesn't exist"
Если фильм существует, спросить пользователя два параметра: имя оценивающего и его оценку от 0 до 10.
Вывести на экран сообщение об успешном добавлении рейтинга:
A rating has been added for Interstellar: Rick rated it 9

Просматривать рейтинг для всех фильмов
Программа выводит средние рейтинги для всех фильмов
Interstellar is rated 7.7
Django Unchained is rated 9.5
Если рейтинга для фильма нет то выводить сообщение:
Rating is not yet available for movie_name

Указания:
В программе необходимо использовать бесконечный цикл для ввода команд.
Добавить пункт "Выход", который завершит программу.
Если пользователь вводит рейтинг, не попадающий в интервал от 1 до 10, выводить сообщение об ошибке и не добавлять этот рейтинг.

Показать ответ
Ответ:
Adilkin
Adilkin
31.01.2021 19:10
uses crt; var s:string;     c:char;     m:set of char;     n,i,k,p:byte; begin writeln('Введите текст из строчных латинских букв, окончаание ввода Enter'); s:=''; repeat c:=readkey; if c in ['a'..'z'] then  begin   write(c);   s:=s+c;  end; if c=#13 then writeln until c=#13; n:=length(s); m:=[]; for c:='a' to 'z' do  begin   k:=0;   for i:=1 to n do   if s[i]=c then k:=k+1;   if k>1 then m:=m+[c];  end; if m=[] then write('Нет букв, встречающихся более 1 раза') else  for c:='a' to 'z' do  if c in m then write(c) end.
0,0(0 оценок)
Ответ:
nicsiberia
nicsiberia
19.05.2020 06:15
Var   a: array[1..20,1..20] of integer;   n,m,i,j,min,jm,x: integer; begin   randomize;   write('Введите размеры массива: ');   readln(n,m);   writeln('Исходный массив:');   for i:=1 to n do   begin     for j:=1 to m do     begin       a[i,j]:=random(19)-9;       write(a[i,j]:4);     end;     writeln;   end;   min:=0;   for i:=1 to n do min:=min+a[i,1];   writeln('Сумма элементов 1-го столбца = ',min);   jm:=1;   for j:=2 to m do   begin     x:=0;     for i:=1 to n do       x:=x+a[i,j];     writeln('Сумма элементов ',j,'-го столбца = ',x);     if x<min then     begin       min:=x;       jm:=j;     end;   end;   writeln('Минимальная сумма в ',jm,'-м столбце');   writeln('Полученный массив:');   for i:=1 to n do   begin     for j:=1 to m do     begin       if j<>jm then a[i,j]:=a[i,jm];     write(a[i,j]:4);     end;     writeln;   end;   readln; end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота