В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
настя7566
настя7566
09.06.2021 07:52 •  Информатика

Нужно написать программу, которая определяет, попадает ли точка с заданными координатами в серую область (см. рисунок) или нет. как это можно реализовать в c++?

Показать ответ
Ответ:
dashatyueet
dashatyueet
17.08.2020 02:21
1. Для цикла For есть решение выложенное выше  от Srzontmp.

2. Почти ничего не меня получим код для цикла while:
var
  i, n, k: integer;
begin
  i := 2;
  readln(n);
  while i <= n div 2 do begin
    if (n mod i) = 0 then k := i;
    i:=i+1;
    end;
  writeln('наибольший делитель ', n, ' = ', k);
end.

3. Аналогично для цикла Repeat:
var
  i, n, k: integer;
begin
  i := 2;
  readln(n);
  repeat
    if (n mod i) = 0 then k := i;
    i:=i+1;
  until i> n div 2;
  writeln('наибольший делитель ', n, ' = ', k);
end.
0,0(0 оценок)
Ответ:
привет948
привет948
24.10.2021 03:42
1)
площадь изображения 35.56×35.56 = 1264.51 квадратных дюймов.
количество точек в квадратном дюйме 1200×1200 = 1 440 000 точек
количество точек во всем изображении
1 440 000 * 1264.51 = 182 089 440 000
глубина цвета 16 бит. 3 цвета RGB * 16 = 48бит на точку
Итого 182089440000 * 48 = 8740293120000 бит
8740293120000 / 8 бит в байте / 1024 байт в КБ /1024 кб в мб / 1024 мб в гб = 865,39 Гигабайт

2)
для палитры в 4 цвета небоходимо 2^n=4, n=2бита
55*55 = 3025 пикселя * 2 бита на пиксель = 6050бит

3)
изображение 12,7×12,7 см.
Разрешающая сканера — 600×1200 dpi,
глубина цвета — 32 бита.
в 1дюйме 2,54 см,  12,7см/2,54 см = 5 дюйм
Изображение 5 * 5 = 25 квадратных дюймов
600*1200 = 720 000 точек на квадратный дюйм
720 000 * 25 = 18 000 000 точек на изображение

глубина цвета 32 бит. 3 цвета RGB * 32 = 96 бит на точку
Итого 18 000 000 * 96 = 1 728 000 000 бит / 8 бит в байте =
216 000 000 байт
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота