В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Аленчік
Аленчік
07.07.2022 12:13 •  Информатика

Нужно написать программу, которая выводит таблицу степеней двойки (от нулевой до десятой).

На языке php

Показать ответ
Ответ:
andreyrodrigo2
andreyrodrigo2
11.12.2021 18:12
 8 единиц 3 разряда, 4 единицы 1 разряда 2 единицы 3 разряда, 9 единиц 2 разряда*3 единицы 3 разряда, 6 единиц 2 разряда 7 ед. 3 разряда, 5 ед. 1 разряда*6 единиц 3 разряда 8ед. 3 разряда, 5 ед. 2 разряда, 8 ед.1разряд4. Запиши числа, в которых:6 сот. 5 ед. 5 сот. 7дес. 6 ед. 9 сот. 7дес. 8 сот. 3дес. 7 ед8 сот. 1 дес. 5 ед. 6 сот. 5 сот. 6 ед. 5 сот. 9 дес. 4 ед.2 сот. 5 дес. 9ед. 7 сот. 6 дес. 5 ед. 5 сот. 9 дес. 4 ед. 2 сот. 7 дес. 5 ед.5 сот. 6 дес. 6 сот. 3 дес. 2 ед. 2 сот. 7 дес. 5 ед 3 сот. 2 дес. 7 ед.1 сот. 4 дес. 5 ед. 7 сот. 9 дес. 3 ед. 3 сот. 9 дес. 3 сот. 2 дес . 7 ед.
0,0(0 оценок)
Ответ:
gallavich2004
gallavich2004
03.02.2020 10:58
Числа являются взаимно простыми, если их наибольший общий делитель равен 1. Используя это свойство, напишем программу:
var
  a, b, c: integer;

{НОД двух чисед}
function gcd(a, b: integer): integer;
var t: integer;
begin
  while b > 0 do
  begin
    t := b;
    b := a mod b;
    a := t;
  end;
  gcd := a;
end;

{Проверка трех чисел на взаимную простоту}
function isCoprime(a, b, c: integer): boolean;
begin
  isCoprime := gcd(gcd(a, b), c) = 1;
end;

begin
  read(a, b, c);
  if isCoprime(a, b, c) then write('Числа взаимно простые')
                        else write('Числа не являются взаимно простыми');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота