В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
leksutin1
leksutin1
30.08.2021 14:25 •  Информатика

Нужно написать программу на c++, которая будет рисовать полый квадрат из решеток(#) используя вложенный цикл.
Вводится одна переменная: длина стороны

Показать ответ
Ответ:
Tles
Tles
23.08.2020 23:20

#include <iostream>

int main()

{

   int len, i, j;

   // Русский язык в консоли

   setlocale(LC_ALL, "Russian");

   std::cout << "Введите длину стороны: ";

   std::cin >> len;

   for (i = 0; i < len; i++)

   {

       for (j = 0; j < len; j++)

       {

           if ((j == 0) || (j == len - 1) || (i == 0) || (i == len - 1)) std::cout << "#";

           else std::cout << " ";

       }

       std::cout << std::endl;

   }

   

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота