Нужно написать программу на Java
Дана матрица размера M × N. Найти максимальный среди минимальных элементов ее строк. Есть код на Паскале
const
rows = 10; { <-- Количество строк }
columns = 10; { <-- Количество столбцов }
var
A: array[1..rows, 1..columns] of integer;
i, j, M, N: byte;
MinElem, MaxMinElem: integer;
begin
repeat
write('M = ');
readln(M)
until (M >= 1) and (M <= rows); { <-- Количество строк от 1 до rows }
repeat
write('N = ');
readln(N)
until (N >= 1) and (N <= columns); { <-- Количество столбцов от 1 до columns }
{ Формируем и выводим матрицу: }
randomize;
writeln('Случайная матрица ', M, 'x', N, ':');
for i := 1 to M do begin
for j := 1 to N do begin
a[i, j] := -100 + random(200); { <-- Случайный элемент -100..99 }
write(a[i, j]:4);
if j = 1 then MinElem := a[i, j] { <-- Инициализация минимального элемента }
else { Сравниваем остальные элементы с минимальным: }
if a[i, j] < MinElem then MinElem := a[i, j]
end;
if i = 1 then MaxMinElem := MinElem { <-- Инициализация максимального минимума }
else
if MinElem > MaxMinElem then MaxMinElem := MinElem;
writeln
end;
writeln;
writeln('Максимальный среди минимальных элементов строк: ', MaxMinElem);
readln
end.
i, j, k : word;
f : boolean;
function isSpace(ch : char) : boolean;
begin isSpace := false;
if ch = ' ' then isSpace := true;
end;
begin f := false;
repeat j := 0;
writeln('введите строку, состоящую из 2 слов');
readln(s);
for i := 1 to length(s) do
if isSpace(s[i]) then
begin
inc(j);
k := i; end;
if j =1 then f := true;
until f;
write(copy(s, k + 1, length(s)), ' ', copy(s, 1, k - 1));
end.
недавно такую писала :)
Информационный объем I = 44100 Гц * 5 * 60 с * 16 бит = 211680000 бит = 26460000 байт = 25839,84375 Кбайт = 25,23422241210938 Мбайт
Задание 2
I = 1,3 Мбайт t = 1 мин Частота дискретизации v = 1,3 * 1024 * 1024 * 8 бит / 60 с / 8 бит = 22719,147 Гц
Задание 3
I = 5.1 Мбайт, t = 2 минуты, v = 22050 Гц Разрядность аудиоадаптера i = 5.1 * 1024 * 1024 * 8 бит / (2 * 60) с / 22050 Гц = 16,1685 бит (округленно 16 бит)
Задание 4
I = 0.01 Гбайт, i = 16 бит, v = 44100 Гц Время t = 0,01 * 1024 * 1024 * 1024 * 8 бит / 16 бит / 44100 Гц = 121 с (округляем до 120 с)