Нужно написать программу на с++. идет n-я секунда суток. определить, сколько полных часов и полных минут до этого момента. + отформатировать исходный код программы. + определить ограничения на задаваемые пользователем значения и не допустить ввода неверных щначений
#include<iostream.h>
using namespace std;
int main()
{
int n=0;
cout<<"Введите секунды."<<endl;
cin>>n;
if(n>60*60*24)
{
cout<<"Неправельный ввод: в сутках меньше, чем "<<n<<" секунд полных часов полных минут: "<<(n-n%60)/60<<endl;
}
system("pause");
return 0;
}
/*
В некоторых компиляторах нельзя выводить русский текст таким образом, нужно выводить английский текст или второй вариант программы:
#include<iostream.h>
#include<windows.h>
using namespace std;
char bufRus[256];
char* Rus(const char* text)
{
CharToOem(text, bufRus);
return bufRus;
}
int main()
{
int n=0;
cout<<Rus("Введите секунды.")<<endl;
cin>>n;
if(n>60*60*24)
{
cout<<Rus("Неправельный ввод: в сутках меньше, чем ")<<n<<Rus(" секунд полных часов полных минут: ")<<(n-n%60)/60<<endl;
}
system("pause");
return 0;
}
P.S сорри, что не увидел только сейчас.
*/