Нужно написать программу на с++ напишите программу, которая вычисляет выражение, состоящее из трех чисел и двух знаков (допускаются только знаки «+» или «–»). выражение вводится как символьная строка, все числа целые. пример: введите выражение: 12-3+45 ответ: 54
Program zadacha1;
uses crt;
const N=5; //размер массива
var m:array[1..n] of integer;
i:integer;
Begin
Writeln('Исходный массив');
For i:= 1 to n do
//readln(m[i]); //для ручного ввода оставьте эту строку
begin // для
m[i]:=random(101)-50; // случайного
Writeln(m[i]); // эти
end; //
Writeln('Прямой вывод');
For i:=1 to n do
writeln(m[i]);
Writeln('Обратный вывод');
For i:=1 to n do
writeln(m[n+1-i]);
End.
Program zadacha2;
uses crt;
const N=5; // размер массива
var m:array[1..n] of integer;
i:integer;
Begin
Writeln('Исходный массив');
For i:= 1 to n do
//readln(m[i]); //для ручного ввода оставьте эту строку
begin // для
m[i]:=random(101)-50; // случайного
Writeln(m[i]); // эти
end; //
Writeln('Вывод');
For i:=1 to n do
if i mod 2 = 0 then writeln(m[i]);
End.
Program zadacha3;
uses crt;
const N=5; // размер массива
var m:array[1..n] of integer;
i:integer;
Begin
Writeln('Исходный массив');
For i:= 1 to n do
//readln(m[i]); //для ручного ввода оставьте эту строку
begin // для
m[i]:=random(101)-50; // случайного
Writeln(m[i]); // эти
end; //
Writeln('Вывод');
For i:=1 to n do
if (n+1-i) mod 2 <> 0 then writeln(m[n+1-i]);
End.
1) Платное - ты платишь за возможность использования полного функционала программы единажды.
Бесплатное - полный функционал программы распространяется бесплатно
Условно-беспланое - программное обеспечение, распространяемое бесплатно, но имеющее платные "модули"
2) Системное - все программы и компоненты, поставляемые вместе с операционной системы, загружаемые с загрузочного диска независимо от желания пользователя.
Прикладное - все программное обеспечение, установленное пользователем.