В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
shcherboroma
shcherboroma
30.07.2021 02:53 •  Информатика

Нужно написать программу на языке паскаль, для решения этого уравнения..​

Показать ответ
Ответ:
Evo4ka111
Evo4ka111
13.03.2023 05:07

55:5=11

365:11≈33(34) берём "34", чтобы перехлестнуть 365.

Так как 11-ый член является замыкающим (перехлёстывающим 365), тогда смотрим по ближайшим:

34*10=340 (340+34=374) - подходит, но это не максимум!

365 mod 10= 36, а это значит, что последующий член будет больше 365, а именно 395.

В задании сказано, что d должно быть максимальным, а "34" - это допустимое, но не максимально число, удовлетворяющее условию, даже минимальное (по результату).

Проверка:

34*11=374, значит, когда на экране выведется s:=340, n:=50, то, зайдя по следующему циклу, получится, что s:= 374, n:=55. На следующий цикл программа не пойдёт.

ответ: d=34. 

0,0(0 оценок)
Ответ:
Анимешник0
Анимешник0
07.01.2023 21:15
Задание 2, 1:
program zadacha1;
uses crt;
var x, y: real;
begin
clrscr;
write('enter x: ');
readln (x);
x:=(x*pi)/180; // в Паскале используется измерение в радианах, здесь мы
// переводим из градусов (так как мы задаем значение в градусах) в радианы
y:=sqr(cos(x))+sqr(sin(x))*sin(x);
writeln ('y=', y:0:4);
readkey;
end.

2
program zadacha2;
uses crt;
var y: real;
begin
clrscr;
y:=sqr(sin(pi))+ pi/2;
writeln ('y=', y:0:4);
readkey;
end.

3
program zadacha3;
uses crt;
var x, y: real;
begin
clrscr;
write ('enter x: ');
readln (x);
x:=(x*pi)/180;
y:=sin(x)/cos(x) + 0.25;
writeln ('y=', y:0:4);
readkey;
end.

4
program zadacha4;
uses crt;
var x, y, z: integer;
begin
clrscr;
write ('enter x, z');
readln (x, z);
y:=abs(x)+2*abs(z);
writeln ('y=', y:0:4);
readkey;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота