В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
uapavlovaoy4dah
uapavlovaoy4dah
09.10.2021 20:35 •  Информатика

Нужно написать программу на языке паскаль. С клавиатуры вводятся длины сторон К
прямоугольников. Посчитать количество вертикально
расположенных и количество горизонтально
расположенных прямоугольников, исходя из того, что
сторона А всегда параллельна оси Х, а сторона В -
оси У.

Показать ответ
Ответ:
poli143
poli143
29.11.2021 04:46

var

 a,b,k,i,k1:integer;

begin

 write('Сколько фигур: '); readln(k);

 b:=0; k1:=0;

 for i:=1 to k do

   begin

     write('Стороны ',i,'-го треугольника(A B): '); readln(a,k);

     if a>=k then  

       if a>k then  

         inc(b)

           else inc(k1);

   end;

 writeln('Горизонтальных: ',b);

 writeln('Вертикальных: ',i-b-k1);

 if k1<>0 then

 writeln('Квадратов: ',k1);

end.

Если моё решение вам, пометьте его лучшим !

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота