В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ZABENOK123
ZABENOK123
04.04.2021 20:24 •  Информатика

Нужно написать программу на языке Паскаль
Условие:
Напишите программу,которая вводит с клавиатуры 3 целых числа и записывает в логическую переменную True,если среди введенных чисел есть хотя бы одно трехзначное

Показать ответ
Ответ:
валентинка20
валентинка20
13.10.2020 19:06

var a,b,c,x:integer;

var true : array [1..3] Of integer ;

begin

readln(a,b,c);

if (a div 100 < 10 )and (a div 100 > 1) then

begin

True[1]:=a;

True[2]:=b;

True[3]:=c;

end;

if (b div 100 < 10 )and (b div 100 > 1) then

begin

True[1]:=a;

True[2]:=b;

True[3]:=c;

end;

if (c div 100 < 10 )and (c div 100 > 1) then

begin

True[1]:=a;

True[2]:=b;

True[3]:=c;

end;

write(true);

end.

Объяснение:

       если не надо в конце выводить true то можешь просто удалить эту строку

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота