В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
lida105
lida105
02.03.2021 19:20 •  Информатика

Нужно написать программу на языке с++ которая должна:
проверить трехзначное число на четность и найти сумму его цифр, если число четное, или произведение его цифр, если число нечетное.

Показать ответ
Ответ:
snejanas1
snejanas1
10.10.2020 16:24

#include <iostream>

using namespace std;

int main()

{

   int n;

   cin >> n;

   n = abs(n); // если введут отрицательное

   if(n > 99 && n < 1000)

   {

       int d1, d10, d100;

       d1 = n % 10;

       d100 = n / 100;

       d10 = n / 10 % 10;

       int r;

       if(n % 2 == 0)

           r = d100 + d10 + d1;

       else

           r = d100 * d10 * d1;

       cout << r;

   }

   else

       cout << "Число не трехзначное";

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота