В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Celovek21
Celovek21
26.07.2021 00:19 •  Информатика

Нужно написать программу, в которой будет выводиться сумма всех чисел, в которых есть повторяющиеся цифры (например 22,33,44,100,101,202,110,202 и т.д). так до можете хоть на паскале, где угодно. только укажите в своем ответе программу, на которой писали.

Показать ответ
Ответ:
Maximus20000
Maximus20000
03.10.2020 19:56
Программа на паскале:
var a,c,s:integer;
m:set of 0..9;
b:boolean;
begin
s:=0;
for a:=10 to 10000 do
 begin
 m:=[];
 b:=false;
 c:=a;
 while c<>0 do
  begin
  if (c mod 10) in m then b:=true;
  m:=m+[c mod 10];
  c:=c div 10;
  end;
 if b then s:=s+a;
 end;
writeln('s = ',s);
end.

Результат:
s = 24727105
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота