Нужно написать программу, в которой в зависимости от значения погоды выводится сообщение о том, что можно или нельзя купаться. Согласно условиям, купаться можно только при температуре строго больше 15.
Варианты вывода данных:
"Купаться можно"
"Купаться нельзя"
Паскаль
Var
A:integer;
P:real;
Begin
P:=1;
For A:= 100 to 405 do
if A mod 13 = 0 then P:=P*A;
WriteLn('P = ',P);
End.
Результат работы программы:
P = 8.85587927807922E+56
Вторая программа:
Var
A:integer;
P:real;
Begin
P:=1;
For A:= 11 to 36 do
if A mod 2 = 0 then P:=P*A;
WriteLn('P = ',P);
End.
Результат работы программы:
P = 4.37068711644365E+17
Третья программа:
Var x:real;
Begin
WriteLn('y(x) = 5*x +6');
x:=1;
Repeat
WriteLn('y(',x:0:3,') = ',5*x+6);
x:=x+0.4
Until x>4;
End.
Результат работы программы:
y(1.400) = 13
y(1.800) = 15
y(2.200) = 17
y(2.600) = 19
y(3.000) = 21
y(3.400) = 23
y(3.800) = 25
var
i: integer;
A: array [1..20] of integer;
begin
randomize;
writeln('Массив: ');
for i:=1 to 20 do A[i]:=random(21)-10;
for i:=1 to 20 do write(A[i]:5);
writeln;
writeln('Каждый пятый эелемент массива: ');
for i:=1 to 20 do if i mod 5 = 0 then write(A[i]:5);
end.
2.
var
x,i: integer;
A: array [1..20] of integer;
begin
randomize;
writeln('Массив: ');
for i:=1 to 20 do A[i]:=random(11);for i:=1 to 20 do write(A[i]:5);
writeln;
writeln('Натуральные числа в диапазоне [5..10]: ');
for i:=5 to 10 do write(A[i]:5);
writeln;
x:=1;
writeln('Их произведение: ');
for i:=5 to 10 do x:=A[i]*x;
write(x:5);
end.