В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
tearprincess200225
tearprincess200225
26.06.2021 00:38 •  Информатика

Нужно написать программу в Паскале:
"Найти максимальный и минимальный элементы массива, состоящего из 8 элементов, и поменять их местами. Полученный массив напечатать в виде столбца".
(Массив одномерный)

Показать ответ
Ответ:
spritemax11
spritemax11
15.11.2021 17:47
Скорее всего, условие задачи сформулировано некорректно, ибо составить программу, содержащую не более пяти команд не получится, и сейчас объясню почему.

Так как нужно из числа 4 получить число 80, то первая команда не может являться "2", в противном случае мы уйдем в отрицательные числа. Тогда первая команда - "1", и теперь нам нужно из числа 20 получить число 80. Рассмотрим несколько случаев, когда последней командой мы получаем число 80.

1 случай.

Если последняя команда - "1", то это возможно, когда предпоследний результат будет равен 16, однако так как наша траектория точно содержит число 20, которое кратно 5, то, применяя далее наши команды, мы всегда будем получать число, кратное 5, а нам нужно получить 16. Противоречие.

2 случай.

Теперь рассмотрим ситуацию, когда последняя команда - "2". То есть предпоследний результат равен 85. Если получать число 85 командой "1", то траектория должна содержать число 17. Из соображений  кратности (см. 1 случай) это невозможно. Значит вторая с конца команда должна являться "2". Аналогично рассуждая, приходим к выводу о том, что и третья, и четвертая команды с конца тоже должны быть "2". То есть наша траектория имеет вид 1*2222, причем на месте "*" должна быть такая траектория команд, которая позволит получить из числа 20 число 100. Ясно, что наименьшая траектория будет 112222, но она содержит 6 команд. Противоречие.

Получается, что из числа 4 получить число 80 программой, которая бы содержала не более 5 команд, действительно не получится. Но если говорить о наименьшей траектории, то 112222 - будет являться ответом на эту задачу.
0,0(0 оценок)
Ответ:
Кисулятв
Кисулятв
19.03.2022 09:54

1)

var

s,r:string;

i:integer;

begin

readln(s);

r:='';

for i:=1 to length(s) do

if s[i]<>'a' then r:=r+s[i];

writeln(r);

end.

2)

текст разделяем знаками препринания


var
t: array [1..100] of string;
p, s, r: string;
f, i, j, k: integer;

begin
p := ' ,.!?;:-';
readln(s);
k := 0;
r := '';
for i := 1 to length(s) do
begin
f := 0;
for j := 1 to length(p) do
if s[i] = p[j] then f := 1;
if f = 0 then r := r + s[i]
else
begin
k := k + 1;
t[k] := r;
r := '';
end;
if i=length(s) then
begin
k := k + 1;
t[k] := r;
end;
end;
for i := k downto 1 do
write(t[i], ' ');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота