В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
edinorogserezha1
edinorogserezha1
11.11.2020 19:17 •  Информатика

Нужно написать программу в с# или исправить мой код, мой код ниже за , нужно что бы программа была рабочая при изменении начальных параметров что бы менялись ответы
using System;
namespace ConsoleApp3
{
class Program
{
public static void Main(string[] args)
{
int n = 3;
double s = 1;
for (int i = 1; i <= n; i++)
{
s = s * (1 + 1 / (i * i));
}
Console.WriteLine("S={0:f3}", s);
Console.ReadKey();
}
}
}


Нужно написать программу в с# или исправить мой код, мой код ниже за , нужно что бы программа была р

Показать ответ
Ответ:
denjis
denjis
02.03.2022 18:40

Відповідь:

using System;

namespace ConsoleApp3

{

class Program

{

public static void Main(string[] args)

{

int n = Convert.ToInt32(Console.ReadLine());

double s = 0;

for (int i = 1; i <= n; i++)

{

s += s * (1 + 1 / (i * i));

}

Console.WriteLine("S={0:f3}", s);

Console.ReadKey();

}

}

}

0,0(0 оценок)
Ответ:
НЕВЕСОМАЯ67
НЕВЕСОМАЯ67
02.03.2022 18:40

// В вашем коде сразу бросается в глаза деление 1 / (i * i). Тут 1, i -- это int => i*i тоже int. В итоге делим int на int. И результат получаем соответствующий. Обязательно узнайте про целочисленное деление

using System;

namespace ConsoleApp1

{

   internal class Program

   {

       private static void Main()

       {

           Console.Write("Enter n: ");

           int n = int.Parse(Console.ReadLine());

           if (n < 1)

           {

               Console.WriteLine("incorrect value");

               return;

           }

           double res = 1;

           for (int i = 1; i <= n; i++)

               res *= 1 + 1 / Math.Pow(i, 2);

           Console.WriteLine($"Result: {res}");

           Console.ReadLine();

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота