В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Nika31303
Nika31303
09.05.2022 21:57 •  Информатика

Нужно написать программу вычисления объёма усеченной пирамиды , в паскаль . v=h(sосн1+sосн2+корень(sосн1 sосн2))/3 . в паскаль

Показать ответ
Ответ:
Кимиджими3
Кимиджими3
05.10.2020 00:16
Var
  h,s1,s2,v:real;
begin
  Write('Площадь нижнего основания пирамиды: '); Read(s1);
  Write('Площадь верхнего основания пирамиды: '); Read(s2);
  Write('Высота пирамиды: '); Read(h);
  v:=h*(s1+s2+sqrt(s1*s2))/3;
  Writeln('Объем пирамиды: ',v)
end.

Пример
Площадь нижнего основания пирамиды: 28
Площадь верхнего основания пирамиды: 17.5
Высота пирамиды: 9
Объем пирамиды: 202.907830863536
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота