В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Deztroyer
Deztroyer
19.08.2022 14:13 •  Информатика

нужно написать программу: Вычислить произведение последовательности {arccos()+cos()+1} для заданного n.

Показать ответ
Ответ:
Наташа1358064225
Наташа1358064225
04.02.2023 20:35
Pascalabc.net 3.4.0, сборка 1675 от 12.06.2018 внимание! если программа не работает, обновите версию! procedure println(self: array of real); extensionmethod; begin   self.batch(5).foreach(s->           begin foreach var p in s do write(p: 15: 10); writeln end);   writeln(min(15*(self.count div 2),38)*'- ') end; begin   var m: =arrgen(readinteger('n='),i-> cos(i),1); m.println;   var (a,b): =readreal2('введите границы a b: ');   writeln('число элементов на интервале [',a,',',b,'] равно ',       m.where(t-> t.between(a,);   write('сумма элементов, расположенных после максимального, равна ');   var imax: =m.indexmax;   (m? [imax+1: ].sum).println;   writeln('элементы, по убыванию модулей');   m: =m.orderbydescending(t-> abs(; m.println; end.
0,0(0 оценок)
Ответ:
dashasapleva6
dashasapleva6
23.05.2020 17:27
 
program Project2;
{$APPTYPE CONSOLE}
uses
SysUtils,windows;

var a,b:array of real;   
 i:byte; 
 cs,sk,da,db:real;    n:integer;
begin
SetConsoleOutputCP(1251);
randomize;
writeln('Введите n');
readln(n);
Setlength(a,n);
Setlength(b,n);
writeln('Вектор À');
for i:=0 to high(a) do 
begin 
 a[i]:=-5+10*random;
  write(a[i]:5:1);
 end;
writeln;
writeln('Вектор B');
for i:=0 to High(b) do
 begin 
 b[i]:=-5+10*random;
  write(b[i]:5:1);
 end;
writeln;
{Скалярные произведения и длинны векторов}
sk:=0;
da:=0;
db:=0;
for i:=0 to n-1 do 
begin 
 sk:=sk+a[i]*b[i];
  da:=da+sqr(a[i]);
  db:=db+sqr(b[i]); 
end;
{Косинус}
cs:=sk/sqrt(da)/sqrt(db);
write('Cos(aльфа)=',cs:0:3);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота