В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
nikitakirillov3
nikitakirillov3
21.10.2022 19:36 •  Информатика

Нужно решить 3 на формирование массива количество элементов произвольное. 1. составить программу , которая формирует массив (автоматически) из целых значений в интервале [0,20], выводит и подсчитывает среднее значение всех элементов массива. 2.составить программу , которая формирует автоматически массив из целых значений в диапазоне [10,30) и подсчитывает количество элементов значение которых больше 15. 3. составить программу , которая формирует массив из целых чисел и подсчитывает количество отрицательных элементов. организовать ввод элементов с клавиатуры. убедительная кто знает норм сайт с объяснением массива или видео скиньте ссылку . заранее за !

Показать ответ
Ответ:
Sashunya20061
Sashunya20061
15.07.2020 16:19
1)
 const     k = 15; 
  var 
     a : array [1..k] of integer; 
     s : real; 
      i : integer; 
begin 
 randomize; 
 s := 0; 
for i := 1 to k do       //Обработка массива чаще всего 
  begin                      //осуществляется в цикле
    a[i] := random(21);         //Формирование
    s := s + a[i];                      //Подсчет суммы элементов
end; 
 s := s / k;                              //Среднее арифметическое (сумма/кол - во)
writeln (s:3:3); 
end.

3)  const     n = 5; 
       var 
           a : array [1..n] of integer; 
            i,k : integer; 
 begin 
k := 0;   
  for i := 1 to n do   
         begin     
  readln (a[i]);             //Считываем элемент
   if a[i] < 0 then          //Если элемент меньше нуля
     k := k +1;                  //счетчик +1
           end;
   writeln (k);
  end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота