В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
suslik030715
suslik030715
13.01.2021 10:06 •  Информатика

Нужно решить на python напишите программу, которая в последовательности натуральных чисел определяет минимальное число, делящееся нацело на 20. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, делящееся нацело на 20. количество чисел не превышает 1000. введенные числа не превышают 30 000. программа должна вывести одно целое число - минимальное число делящееся нацело на 20. входные данные 3 40 240 450 выходные данные 40

Показать ответ
Ответ:
Vishenka220
Vishenka220
26.05.2020 10:43

n=int(input())

min_na20=30000

for i in range(n):

 x=int(input())

 if x<min_na20 and x%20==0:

   min_na20=x

print(min_na20)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота