В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Nastya77777778
Nastya77777778
01.03.2023 04:29 •  Информатика

Нужно решить на языке паскаль. изучаем string. 1.дана строка. написать программу, выводящую сумму порядковых номеров заданного символа. 2.дано предложение состоящее из заглавных букв. в предложении только одно слово в котором 3 буквы. вам нужно написать программу которая найдет это слово и выведет его в файл.

Показать ответ
Ответ:
Madinamkm
Madinamkm
26.08.2020 07:55
//PascalABC.NET 3.2 сборка 1318

Var
  s:string;
  c:char;
  sum,i:integer;
begin
readln(s);
readln(c);
for i:=1 to length(s) do
if s[i]=c then sum+=i;
writeln(sum);
end.

Пример ввода:
konichiva
i
Пример вывода:
11

//2
Var
  f:text;
  s:string;
  i:integer;
begin
readln(s);
var ars:=s.Split;
i:=0;
while ars[i].Length<>3 do
inc(i);
assign(f,'output.txt');
rewrite(f);
write(f,ars[i]);
close(f);
end.
  
Пример ввода:
ARK DRIVE FINISH
Пример вывода в файл output.txt:
ARK
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота