В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
silverfinn
silverfinn
31.05.2021 10:29 •  Информатика

нужно сдать до завтра

Составить программу для вычисления выражения 1^2+2^2+3^2+...+10^2

Показать ответ
Ответ:
misskamii
misskamii
06.05.2020 23:39

Відповідь:

#include <iostream>

using namespace std;

int n, i, j, k;

double d, s;

int main()

{

cout << "Poryadok: " << endl;

cin >> n;

double **a = new double *[n];

for (i = 0; i <= n; i++)

a[i] = new double [n];

double **a1 = new double *[n];

for (i = 0; i <= n; i++)

a1[i] = new double [n];

double *b = new double [n];

double *x = new double [n];

cout << "Vvedite koefficienty i svobodnye chleny " << endl;

for (i = 1; i <= n; i++)

{

for (j = 1; j <= n; j++)

{

cout << "a[ " << i << "," << j << "]= ";

cin >> a[i][j];

a1[i][j] = a[i][j];

}

cout << "b,[ " << i << "]= ";

cin >> b[i];

}

for (k = 1; k <= n; k++) // прямой ход

{

for (j = k + 1; j <= n; j++)

{

d = a[j][k] / a[k][k]; // формула (1)

for (i = k; i <= n; i++)

{

a[j][i] = a[j][i] - d * a[k][i]; // формула (2)

}

b[j] = b[j] - d * b[k]; // формула (3)

}

}

for (k = n; k >= 1; k--) // обратный ход

{

d = 0;

for (j = k + 1; j <= n; j++)

{

s = a[k][j] * x[j]; // формула (4)

d = d + s; // формула (4)

}

x[k] = (b[k] - d) / a[k][k]; // формула (4)

}

cout << "Korni sistemy: " << endl;

for( i = 1; i <= n; i++)

cout << "x[" << i << "]=" << x[i] << " " << endl;

return 0;

}

Пояснення:

0,0(0 оценок)
Ответ:
0987mnbv
0987mnbv
20.12.2022 14:36
// PascalABC.NET 3.0, сборка 1076
begin
  var n:=ReadInteger('Число элементов массива=');
  var a:=ArrRandom(n,-25,25);
  Write('Исходный массив: '); a.Println;
  var k:=a.Where(x->sqr(x)>sqr(a[0])).Count;
  if k>0 then Writeln
    ('Найдено ',k,' элементов, квадрат которых больше квадрата первого')
  else Writeln
    ('Нет ни одного элемента, квадрат которого больше квадрата первого')
end.

Тестовое решение:
Число элементов массива=15
Исходный массив: 11 12 -11 -3 -16 -22 22 4 -4 -1 -16 -9 -19 4 16
Найдено 7 элементов, квадрат которых больше квадрата первого
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота