В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Нужно сделать алгоритм с описанием кода в python. Обработка нескольких исключений, использование всех блоков try

1. Напишите программу, которая будет находить монотонность ряда n чисел до тех пор, пока пользователь не нажмет клавишу прерывания. Вывод программы – количество смен монотонности чисел. Предусмотрите исключения ввода строки, а также исключение KeyboardInterrupt

Показать ответ
Ответ:
кэт324
кэт324
01.11.2021 18:15

фон- основной цвет

ЭКОНОМИЧНОСТЬ — одна из основных составляющих успеха хозяйственной деятельности, суть которой заключается в разумной и рациональной экономии

ЭРГОНОМИКА-Научно-практическая дисциплина, изучающая трудовые процессы с целью создания оптимальных условий труда росту его производительности.

Программи́ст — специалист, занимающийся программированием, то есть созданием компьютерных программ.

Пользователь — лицо или организация, которое использует действующую систему для выполнения конкретной функции.

цвет-окраска

программа-Изложение содержания и цели деятельности политической партии, организации или отдельного деятеля.

дизайн-Художественное конструирование предметов быта, интерьеров, промышленных изделий и т. п.

проект-Разработанный план сооружения, устройства чего-н.

меню-Подбор кушаний, а также листок с перечнем их.

качество-Наличие существенных признаков, свойств, особенностей, отличающих один предмет или явление от других.

диалог-литературная или театральная форма устного или письменного обмена высказываниями между двумя и более людьми

интерфейс-граница между двумя функциональными объектами, требования к которой определяются стандартом;

звук-Воспринимаемое слухом физическое явление, порождаемое колебательными движениями частиц воздуха или другой среды.

0,0(0 оценок)
Ответ:
MishaDunaev
MishaDunaev
23.06.2020 02:11
{Дано двузначное число.
Определить:
а) является ли сумма его цифр двузначным числом;
б) больше ли числа а сумма его цифр}
var n, s : byte;
    a:integer;
begin
 writeln('введите двузначное число');
 readln(n);
{определение суммы цифр числа div - целая часть от деления, mod - остаток от деления}
 s:=n div 10 + n mod 10;
 writeln('сумма цмфр числ', n:5, 'равна',s:5);
 if s>9 then writeln('сумма цифр двузначное число', s)
  else writeln('сумма цифр не двузначное число', s);

 writeln('введите число а');
 readln(a);
 if s>a then writeln('сумма цифр', n,' больше ли числа ', a)
  else writeln('сумма цифр', n,' меньше числа ', a);

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота