В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
lovenastya87
lovenastya87
18.04.2021 01:42 •  Информатика

Нужно сделать в паскале на столе лежит кучка монет. в этой кучке ровно n монет, каждая из которых имеет стоимость a[i]. можно выбрать только 3 монеты из кучки. ваша определить максимальную сумму, которую можно набрать? формат ввода: в первой строке находится число n - количество монет в кучке. далее следует n целых чисел a[i] - стоимость i-той монеты. 0 < = a[i] < = 10 3 < = n < = 10 формат вывода: одно число - ответ на .

Показать ответ
Ответ:
Лина5г
Лина5г
18.06.2020 11:59
Программа написана на языке Паскаль.
uses crt;
var
m, n,t, i : integer;
a : array [1..10] of integer;
max : array [1..10] of integer;
begin
clrscr;
m := -100;
write ('N ='); readln (n);
for i:= 1 to n do 
read (a[i]);
for i:= 1 to n do
if a[i]>=m then begin
max[1]:= a[i]; m:=max[1]; end;
 for i:= 1 to n do if t<>1 then
if a[i]=max[1] then begin a[i]:=0; t:= t+1; end; 
 m:= -100;
for i:= 1 to n do
if a[i]>=m then
begin
max[2]:= a[i]; m:=max[2]; 
end;
 t:= 0;
 for i:= 1 to n do
 if t<>1 then
if a[i]=max[2] then
begin a[i]:=0; t:= t+1; end; 
 m:= -100;
for i:= 1 to n do
if a[i]>=m then
begin max[3]:= a[i]; m:=max[3]; end; 
t:= 0; 
for i:= 1 to n do if t<>1 then
if a[i]=max[3] then begin
a[i]:=0; t:= t+1; end;
  m:= -100;
 writeln;
for i := 1 to 3 do
t:= max[i]+t;
writeln ('otvet ',t);
readkey;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота