В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
weazelhubozcy1c
weazelhubozcy1c
31.12.2022 22:34 •  Информатика

Нужно составить программу на нахождения значения выражения

у= 2.5* cos a+ x/(d+8)

А. Интерфейс необходимо создать понятным для пользователя.

В. Необходимо описать действия любых двух компонентов программы:

Компонент Действия

С. Написать код программы в тетради
ну ответьте по-братски
вы же хорошие человеки

Показать ответ
Ответ:
mashashherbina
mashashherbina
22.05.2022 11:53
1. Какой из объектов может являться исполнителем?

a) Сканер - исполнитель, выполняет активную функцию копирования

b) Альбом - хранилище информации

с) Луна - просто объект

d) Книга - хранилище информации

описания, представления алгоритма в виде определенных слов естественного языка, которым придается значение действия, или команды для исполнителя - это...

a) Алгоритмический язык - инструмент описания алгоритма, для создания одного из его представлений. Является подмножеством ЯП.

b) Язык программирования - инструмент для описания кода программ - одного из видов представлений алгоритма.

c) Блок-схема - одно из видов представления алгоритма, в виде блоков и символов.

d) Естественный язык - слишком широкоспециализированный

3. Что означает свойство алгоритма - результативность?

1) алгоритм должен состоять из команд, однозначно понимаемых исполнителем - (доступность)

2) разбиение алгоритма на конечное число простых шагов - (конечность)

3) выполнение всех команд алгоритма должно привести к определенному результату - алгоритм - представление процесса переработки, трансформации информации. Мы принимаем информацию на входа, преобразуем её и выдаём на выходе. Если полностью убрать из этой последовательности выдачу результата (в любом проявлении), то зачем нам нужен алгоритм? Правильно, он бесполезен.

4) каждая команда должна быть описана в расчете на конкретного исполнителя

0,0(0 оценок)
Ответ:
Nikita67566
Nikita67566
22.11.2022 15:32

import random

check = []

count_res = 0

count = 0

for i in range(7):

   number = random.randint(2, 9)

   if number not in check:

       check.append(number)

       print(number)

       count += 1

   count_res += 1

if count != count_res:

   for j in range(count_res - count):

       for z in range(2, 10):

           if z not in check:

               print(z)

               count += 1

           if count_res - count == 0:

               quit()

Объяснение:

Предлагаю такой вариант. Единственное если изменяешь диапозон( у меня он 2, 9), то в for(у меня он 2, 10) второе число + 1. Ну как видишь( было 2, 9 => 2, 10).

Числа не повторяются, их сколько нужно, но нужно следить, чтобы колво запрашиваемых чисел( это первый for = 7 у меня) было не больше диапозона, иначе числа будут повторятся.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота