Нужно составить программу на паскале (через ). задан список студентов из 7 фамилий. распечатать данный список в столбец и найдите в списке все фамилии, начинающиеся со слога «ма».
//дан целочисленный массив из 30 элементов. Элементы массива могут принимать значения от -10 до 20. //Составьте программу, которая подсчитывает и выводит среднюю температуру по всем дням, //когда были заморозки. Гарантируется, что хотя бы в один день были заморозки
var i,x,y : shortint; s : real; t : array [1..30] of shortint; begin randomize; For i:=1 to 30 do begin t[i]:=random (31)-10; //заполняем таблицу случайным образом (в диапазоне от -10 до 20) writeln (i,' ',t[i]); //строка не обязательная просто позволяет увидеть заполненный массив end; for i:=1 to 30 do begin if t[i]<0 then begin x:=x+t[i]; y:=y+1; end; end; s:=x/y; writeln ('Средняя температура по дням, когда были заморозки ',s:0:2); end.
procedure PrintArray(var a: array100); var i: integer; begin for i := 1 to n do write(a[i]:3, ' '); writeln; end;
begin randomize; for i := 1 to n do a[i] := random(99) - 50;
PrintArray(a);
repeat f := true; for i := 1 to n - 1 do if (a[i] < 0) and (a[i + 1] >= 0) then begin f := false; t := a[i]; a[i] := a[i + 1]; a[i + 1] := t; end; until f; PrintArray(a);
//Составьте программу, которая подсчитывает и выводит среднюю температуру по всем дням,
//когда были заморозки. Гарантируется, что хотя бы в один день были заморозки
var i,x,y : shortint;
s : real;
t : array [1..30] of shortint;
begin
randomize;
For i:=1 to 30 do
begin
t[i]:=random (31)-10; //заполняем таблицу случайным образом (в диапазоне от -10 до 20)
writeln (i,' ',t[i]); //строка не обязательная просто позволяет увидеть заполненный массив
end;
for i:=1 to 30 do
begin
if t[i]<0 then
begin
x:=x+t[i];
y:=y+1;
end;
end;
s:=x/y;
writeln ('Средняя температура по дням, когда были заморозки ',s:0:2);
end.
n = 30;
type
array100 = array [1..100] of integer;
var
a: array100;
i, t: integer;
f: boolean;
procedure PrintArray(var a: array100);
var
i: integer;
begin
for i := 1 to n do
write(a[i]:3, ' ');
writeln;
end;
begin
randomize;
for i := 1 to n do
a[i] := random(99) - 50;
PrintArray(a);
repeat
f := true;
for i := 1 to n - 1 do
if (a[i] < 0) and (a[i + 1] >= 0) then begin
f := false;
t := a[i];
a[i] := a[i + 1];
a[i + 1] := t;
end;
until f;
PrintArray(a);
readln;
end.