В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Нужно составить программу. Найдите среднее арифметическое элементов массива А.
Паскаль!

Показать ответ
Ответ:
Gok3004
Gok3004
19.11.2020 06:42

program svs;

const n=7;

var a:array[1..n] of integer;

i,sum:integer;

sarif:real;

begin

 sum:=0;

 sarif:=0;

 writeln ('введите массив');

 for i:=1 to n do

  begin

  write('введите A[',i,']:');

  readln(a[i]);

  sum:=sum+a[i];

  end;

 sarif:=sum/n;

 writeln ('среднее арифметическое = ',sarif:4:2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота