В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
OTJTu4HuK
OTJTu4HuK
02.04.2022 21:26 •  Информатика

Нужно составить программу обработки данной строки, позволяющую выписать все знаки сравнения и все скобки, сохранив их последовательность

Показать ответ
Ответ:
oleegglazunov
oleegglazunov
06.10.2020 13:58
Теперь уже PascalABC.Net 3.2
var s:string;
i:integer;
begin
readln(s);
for i:=1 to s.Length do begin
  if ((s[i]=')') or (s[i]='(') or (s[i]='>') or (s[i]='<') or (s[i]='=')) then write(s[i]);
  end;
end.
Я надеюсь, <>=() - это все знаки, которые вы перечислили?
0,0(0 оценок)
Ответ:
penina1
penina1
06.10.2020 13:58
// PascalABC.NET 3.2, сборка 1488 от 21.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  ReadlnString('Введите строку:').MatchValues('[()=<>]').Println('')
end.

Пример
Введите строку: Пусть F(x)=3a/x+(x-1)>5x/(2-x), тогда ...
()=()>()
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота