В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Нужно составить программу с repeat,определяющую максимальное из всех введённых вами чисел.(пусть признаком конца ввода чисел является введённое число 0).

Показать ответ
Ответ:
Sashapro111
Sashapro111
26.05.2020 23:20

var
i, e : Integer;
begin

Writeln('Вводите числа:');

i := 0;

repeat
Readln(e);

if e > i then i := e;
until e = 0;

Writeln('Наибольшее число: ', i);

end.

0,0(0 оценок)
Ответ:
cofiabogachova
cofiabogachova
26.05.2020 23:20

Program abc;

uses crt;

const n=30;

var

a:array[1..n] of integer;

i, max:integer;

begin

clrscr; 

for i:=1 to n do

read(a[i]);

max:=a[1];

for i:=2ton do

if a[i]>max then max:=a[i];

write('max=',max);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота