В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
elizavetanikan
elizavetanikan
02.06.2023 18:15 •  Информатика

Нужно составить программу в Pascal ABC, которая будет разворачивать числа, например, 234=432​

Показать ответ
Ответ:
ulashn
ulashn
27.08.2020 23:18

Var

n, m:integer;

a:byte;

Begin

readln(n);

m:=0;

while n>0 do begin

a:= n mod 10;

n:= n div 10

m:= m*10+a

end;

writeln(m) ;

End.

0,0(0 оценок)
Ответ:
anuta136
anuta136
27.08.2020 23:18

Для любого количества символом/цифр

begin

 var stroka := ReadString('Введите число/слово');

 for var i := Length(stroka) downto 1 do

   stroka += stroka[i];

 Delete(stroka, 1, length(stroka) div 2);

 Println('Реверс: ', stroka);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота