В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
sashashenko
sashashenko
13.05.2022 12:35 •  Информатика

нужно составить программу в паскале
Заранее Задание:
Найдите среднее арифметическое элементов массива, заполненного случайными числами от 6 до 21. Размерность массива вводится с клавиатуры. Вывести на экран все элементы.

Показать ответ
Ответ:
geklaoycd9v
geklaoycd9v
12.10.2020 01:34

PascalABC.Net

Varian 1:

begin  var n := ReadInteger('Введите размер массива');  var a := ArrRandom(n, 6, 21);  Print(a, 'Srednee: ', a.Average); end.

Varian 2:

var  f: array[1..100] of integer;  i, sum, N: integer;  srednee: real; begin  Writeln('Введите размер массива: ');  Read(N);  sum := 0;  randomize;  for i := 1 to N do  begin    f[i] := random(6, 21);    write(f[i], ' ');    sum := sum + f[i];  end;  srednee := sum / n;  writeln('Srednee: ', srednee:3:3); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота