Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
ARTiStlll
13.01.2023 21:58 •
Информатика
Нужно составить программу, вычисляющую сумму только положительных чисел из трех вводимых с клавиатуры. в турбо паскале
Показать ответ
Ответ:
Kok1n
01.10.2020 16:45
Program picaso; uses crt;
var a,b,c,s:integer;
begin clrscr;
writeln('A:');read(a);
writeln('B:');read(b);
writeln('C:');read(c);
if(a > 0) then a:=a else a:=0;
if(b > 0) then b:=b else b:=0;
if(c > 0) then c:=c else c:=0;
s:=a+b+c;
writeln(s);
readln;
end.
0,0
(0 оценок)
Ответ:
vikakareva1
01.10.2020 16:45
Var a,b,c,ap,bp,cp:real;
begin
read(a,b,c);
if a>0 then ap:=a else ap:=0;
if b>0 then bp:=b else bp:=0;
if c>0 then cp:=c else cp:=0;
write (ap+bp+cp);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
irinapak1985
07.08.2020 19:01
Напишите программу, которая считывает с клавиатуры последовательность символов и выводит на экран: а)количество считанных десятичных цифр; б)количество четных цифр; в)количество...
танякотя
07.08.2020 19:01
Написать программу, которая определяет, является ли введенное слово палиндромом. выдать сообщeние в msgbox. вывести проверяемое слово в двух вариантах. visual basic....
Boom111111111111
07.08.2020 19:01
При выборе компонентов компьютера необходимо уложиться в заданную сумму. для подбора раз личных вариантов решения указанной использовать табличный процессор (электронные таблицы)....
dsklim2oxkfup
21.02.2022 01:18
Расписание сколько битов информатика...
ura784512
19.04.2021 20:13
Жеке сымсыз байланыс желілерін тиісті сипаттамаларымен сәйкестендір....
апепе1
12.08.2020 21:44
2) ШКОЛЬНИ КЧитаеттекст Вучебнике-3) БабушкаЧитаетПИСЬМО -Определите в каждой ситуации источник информации ...
Варвара75639
31.08.2022 00:04
Задачы Посылки Сообщения А. Необычная зарплатаОграничение времени1 секундаОграничение памяти64MbВводстандартный ввод или input.txtВыводСтандартный вывод И.Пім оutput.txtМаша...
адевале1
22.11.2020 22:10
Назовите программы, позволяющие уменьшить размер файла. опишите два сжатия файла. наименование 1 наименование 2...
елмира1
09.05.2020 21:08
1поколение 2 поколение 3 и 4 соотнести...
xPinkiPai
09.01.2020 04:35
Можно ли выполнить сложение двоичной системе счисления не используя таблицы сложения ответ обоснуйте...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var a,b,c,s:integer;
begin clrscr;
writeln('A:');read(a);
writeln('B:');read(b);
writeln('C:');read(c);
if(a > 0) then a:=a else a:=0;
if(b > 0) then b:=b else b:=0;
if(c > 0) then c:=c else c:=0;
s:=a+b+c;
writeln(s);
readln;
end.
begin
read(a,b,c);
if a>0 then ap:=a else ap:=0;
if b>0 then bp:=b else bp:=0;
if c>0 then cp:=c else cp:=0;
write (ap+bp+cp);
end.