В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
alikrufgffgfgf
alikrufgffgfgf
06.01.2022 00:17 •  Информатика

Нужно вытянуть ! напишите процедуру ввода n элементов массива из файла. отсортируйте по невозрастанию методом простого обмена. (паскаль)

Показать ответ
Ответ:
miwe10
miwe10
02.10.2020 05:05
Var  i,j,n,k: integer; 
 a: array [1..100] of integer;
begin
assign (input,'input.txt');
reset(input);
assign(output,'output.txt');
rewrite(output);
readln (n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do 
for j:=1 to n-i do
 if a[j+1]>a[j]
then begin k:=a[j]; a[j]:=a[j+1]; a[j+1]:=k; end;
for i:=1 to n do
write (a[i],' ');
end.

Входные данные писать в файл input.txt в формате:
n
a[i] a[i+1] a[i+2]...a[n].
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота