Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
яна1764
26.08.2021 21:22 •
Информатика
Нужно задать массив целых чисел. вывести на экран только те значения элементов массива, которые встречаются в нем более одного раза, при этом каждое найденное значение должно быть распечатано столько раз, сколько оно встречается.
Показать ответ
Ответ:
HellyHopta
09.07.2020 15:52
Решение этой задачи на языке С++# include <iostream># include <math.h># include <cmath>using namespace std;int main(){ int b,a[1001] , i = 0 , j = 1 , k = 0; while(cin>>b) { a[j] = b; i++; j++; } for(j = 2; j <= i; j++) { if(((a[j - 1] > 0) && (a[j] > 0))||((a[j - 1] < 0)&&(a[j] < 0))){ cout<<a[j-1]<<" "<<a[j]; return 0; } } return 0;}
0,0
(0 оценок)
Ответ:
Sofff24
09.07.2020 15:52
Program masof;
var ar: array of integer;
i, j, temp, N: integer;
begin
readln(N);
setlength(ar, N+1);
for i:=1 to N do begin readln(ar[i]); end;
for i:=1 to N do begin
temp:=0;
for j:=1 to N do begin if ar[j]=ar[i] then inc(temp); end;
if temp>1 then write(ar[i], ' ');
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
islamghj
01.12.2022 03:59
Составить программу вычисления длины окружности и площади круга по заданному радиусу....
эрика96
20.10.2021 03:51
Ниже приведен фрагмент программы, записанный на языке Паскаль.Было проведено 6 запусков программы, при которых в качествезначений переменных аир вводились следующие пары: (10,4),...
drovniashinaan
24.10.2020 20:48
Средняя скорость пути лыжника на первой половине дистанции была в 3 раза больше, чем на второй. какова средняя скорость движения лыжника на первой половине дистанции, если средняя...
savelevad120
24.10.2020 20:48
Какой дыхания у амёбы и у эвглены зелёной...
Ульяна3330
24.10.2020 20:48
Сократите дроби 6 12. 32 60 . 96 72. 45 9 . 39 91 . 95 38 ....
Аня98788
24.10.2020 20:48
Вычисли корень уравнения 7,4⋅c=25,9...
AlexandraB11092003
24.10.2020 20:48
Площадь первый комнаты 16кв м .площадь второй комнаты в 2раза меньше. чем площадь первой комнати.а площадь третий комнаты на 7 вм м большее.чем площадь второго комнати.чему равно...
Vadim200129
24.10.2020 20:48
Подобрать и написать 3 однокоренных слова(сущ,прил,глаг)с корнями.-...
татар13
24.10.2020 20:48
Сделать анализ по стихотворению 19 октября по плану: 1.биографический комментарий 2.роль пейзажа, с которого начинается стихотворение 3.лирический сюжет 4.смысл формы стихотворения...
DGOTVK
24.10.2020 20:48
Зділянки зібрали 600 кг зерна, -і зерна становило жито, -р- - пшениця, решту - кукурудза. скільки 5 всього кілограмів жита і пшениці зібрали? на скільки кілограмів більше зібрали...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var ar: array of integer;
i, j, temp, N: integer;
begin
readln(N);
setlength(ar, N+1);
for i:=1 to N do begin readln(ar[i]); end;
for i:=1 to N do begin
temp:=0;
for j:=1 to N do begin if ar[j]=ar[i] then inc(temp); end;
if temp>1 then write(ar[i], ' ');
end;
end.