В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
zherukova00
zherukova00
02.05.2022 05:14 •  Информатика

О Анализ
Составьте программу для вычисления математических выражений,
одновременно анализируя использование функций input() и print()
в практических заданиях.
1) 352.985. 25. 3
2) 362 + 1206 + 215554 + 6957 + 628
без спама​

Показать ответ
Ответ:
Lungeluna
Lungeluna
29.02.2020 23:06

yxwz

Объяснение:

Чтобы значение функции (¬x ≡ z) → (y ≡ (w ∨ x)) было ложным, выражение ¬x ≡ z должно быть истинным, а выражение y ≡ (w ∨ x) – ложным. Чтобы первое выражение было истинным, переменные x и z должны иметь противоположные значения: 0 и 1 или 1 и 0.

Рассмотрим третью строку таблицы. Три переменных равны нулю, F = 0. Значит, оставшаяся переменная (переменная 2 в таблице) равна 1, и это z или x. Тогда y = 0, w = 0, и чтобы выражение y ≡ (w ∨ x) было ложным, необходимо, чтобы x = 1. Значит, второй столбец – x. Другой подходящей комбинации с тремя нулями быть не может, значит, в пустых клетках в первой и второй строках таблицы должны стоять единицы.

Поскольку x и z должны иметь разные значения, а x – это переменная 2, из первой и второй строк таблицы видим, что z – переменная 4.

Рассмотрим вторую строку. В ней x = 1, тогда w ∨ x= 1 независимо от значения w, и чтобы выражение y ≡ (w ∨ x) было ложным, необходимо, чтобы y = 0. Получается, что y – переменная 1, w – переменная 3.

0,0(0 оценок)
Ответ:
dimoncool67
dimoncool67
13.06.2021 18:27

<Code>

--- Python 3.8.3 ---

import typing

from typing import Callable

from typing import AnyStr

from typing import Any

import re

import string

def StringCount(RawString: AnyStr, Selector: Callable[[AnyStr], bool], splitter: AnyStr = None) -> int:

   '''Подсчитывает кол-во вхождений элемента, удовлетворяющего условию, в строку или подстроку при заданном splitter'''

   counter = 0

   if splitter:

       ToAnalyse = RawString.split(splitter)

   else:  

       ToAnalyse = list(RawString)

   for item in ToAnalyse:

       if Selector(item): counter += 1  

   return counter

def main():

   Strings = [input() for i in range(int(input()))]

   for s in Strings:

       Uppercase = StringCount(s, lambda p: lambda p: p.isupper())

       Spaces = s.count(' ')

       print(f'String: {s}\nSpaces: {Spaces}\nUppercase: {Uppercase}')

if __name__ == "__main__":

   main()

<\Code>

На скриншотах приложены тесты программы.


Заданы M строк, которые вводятся с клавиатуры. Подсчитать количество пробелов в каждой из строк и ко
Заданы M строк, которые вводятся с клавиатуры. Подсчитать количество пробелов в каждой из строк и ко
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота