В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
enbasmanovan
enbasmanovan
09.07.2021 04:19 •  Информатика

Объясните и напишите код программы на языке с++1. напишите программу, которая сравнивает количество перестановок при сортировке одного и того же массива разными . 2. проведите эксперименты для возрастающей последовательности (уже отсортированной), убывающей (отсортированной в обратном порядке) и случайной.

Показать ответ
Ответ:
12320071
12320071
24.06.2020 13:21

Начнем сначала. Паскаль является строго типизированным языком, значит чтобы использовать переменную, надо её сначала добавить в специальный блок var. 

Константы добавляются отдельно. 

Рассмотрим сперва неольшой пример, не имеющий отношение к твоей задаче:

program task1;

var i:integer;

begin

write("Vvedite i: ");

readln(i);

writeln(i);

end.

Программа просто попросит ввести i, запомнит введенное значение в ячейку с именем i.

Так вот чтобы разрешить использовать ячейку с именем i, мы и должны добавить её var i:integer; (ячейка i в которую можно класть целые числа, integer - целое по английски)

 

Теперь по твоему заданию:

1. в Паскале нет "переменных" чисел,

вот типы, которые есть в Паскале:

 

для целых чисел:
integer, диапазон -32768..32767
byte, диапазон 0..255
word, диапазон 0..65535
shortint, диапазон -128..127
longint, диапазон -2147483648..2147483647

 

для вещественных типов (в такие ячейки можно класть как целые числа, так и числа с точкой)

single (мало значащих цифр)

real (средне значащих цифр)
double (много значащих цифр)
extended (очень много значащих цифр)


логический тип
boolean может быть либо true либо false


Символьный тип
char просто любой символ, из поддерживаемых Паскалем (ASCII кодировка)

 

Таким образом фраза 

"Составить программу описания двух переменных чисел" понята мной как:

"Составить программу описания переменных:"

 

Итак, теперь программа:

program zadacha1;
var
d1,d2,d3:real; {dejstvitelnie, 3 stuki}
i1,i2,i3:integer;{celie, 3 shtuki}
const e=2.71; {Pervaya postojannaya}
g=9.8; {Vtoraya postoyannaya}
gravity=6.61; {Tretjya postoyannaya}
var c1,c2:integer; {dve celie, chislovie}
key:char; {odna simvolnaya}
begin
{zdes' teper' mozhno pisat' programmu}
end.

 

P.S. во вложении этот же исходный код, а на изображении еще и пример как класть значения в эти переменные.

 

Задавайте дополнительные вопросы

 


По информатике(паскаль) составить программу описания двух переменных чисел: трех действительн., трех
0,0(0 оценок)
Ответ:
zamanova05
zamanova05
04.08.2022 19:15

1 Вариант

var a:integer;

begin

writeln('Введите номер месяца: ');

readln(a);

case a of

1:writeln('Зима');

2:writeln('Зима');

3:writeln('Весна');

4:writeln('Весна');

5:writeln('Весна');

6:writeln('Лето');

7:writeln('Лето');

8:writeln('Лето');

9:writeln('Осень');

10:writeln('Осень');

11:writeln('Осень');

12:writeln('Зима');

end;

end.

2 Вариант

var a:integer;

begin

writeln('Введите номер месяца: ');

readln(a);

if (a=12) or (a=1) or (a=2) then writeln('зима');

if (a=3) or (a=4) or (a=5) then writeln('весна');

if (a=6) or (a=7) or (a=8) then writeln('лето');

if (a=9) or (a=10) or (a=11) then writeln('осень');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота