В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
vladfoxi1oysz6h
vladfoxi1oysz6h
24.01.2020 10:46 •  Информатика

Объясните суть этой программы, а конкретнее, что в ней делают функции inc и Dec. Задача: Полоска бумаги имеет размеры А*B клеточек (1≤A,B≤10^6). Каждый раз от неё отрезается квадрат максимального размера до тех пор, пока не получится квадрат. Определите, сколько квадратов получится. Программа на Паскале:
program m_1;
var A:longint;
B:longint;
N:integer;
begin
readln (A,B);
N:=1;
while A<>B do
begin inc(N);
if A>B then Dec(A,B) else
Dec (B,A);
end;
writeln (N)
end.

Показать ответ
Ответ:
ника3931
ника3931
16.10.2020 17:22

Функция inc(x, a) увеличивает х на а единиц.

Функция dec(x, b) уменьшает x на b единиц.

Если количество единиц не указано, то +1, либо -1.

Пока стороны A и B не равны,т.е пока не получится квадрат:

1). Увеличиваем счетчик квадратов N на единицу.

2) . Уменьшаем сторону побольше, отняв длину стороны поменьше. ( "Отрезаем квадрат")

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота