В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
LEXSUS18
LEXSUS18
31.07.2021 15:46 •  Информатика

Объясните задание, я реально не понимаю что от меня хотят "Написать программу, которая выводит число равное количеству цифр 4 в десятичной записи числа"
Желательно, с примерами

Показать ответ
Ответ:
avamini2007
avamini2007
15.10.2020 13:14

#include<iostream>

#include<string>

using namespace std;

int main(){

   string n;

   cin >> n;

   long long ans = 0;

   for(long long i = 0; i < n.size(); i++){

       if(n[i] == '4'){

           ans++;

       }

   }

   cout << ans;

   return 0;

}

Объяснение:

Смотрите, на вход дается какое-то число а программа должна вывести кол-во 4 в этом числе.

Примеры

ввод 14 вывод 1

ввод 444 вывод 3

ввод 16484 вывод 2

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота