Обязательно на basic! Составить программу ввода величины T- времени в течение суток, и выдачи текста: «Вы уже проснулись?», если t<10; «Не пора ли обедать?», если t=12; «Еще не вечер!», если t>=18; «Как работается?», в остальных случаях.
При обращении к ячейке можно использовать описанные ранее ВЗ, А1:G9 и т. д. Такая адресация называется относительной. При ее использовании в формулахExcelзапоминает расположение относительно текущей ячейки. Так, например, когда вы вводите формулу =B1+B2 в ячейку В4, тоExcelинтерпретирует формулу как "прибавить содержимое ячейки, расположенной тремя рядами выше, к содержимому ячейки, расположенной двумя рядами выше".
Если вы скопировали формулу =В1+В2 из ячейки В4 в С4, Excelтакже интерпретирует формулу как «прибавить содержимое ячейки, расположенной тремя рядами выше, к содержимому ячейки двумя рядами выше». Таким образом, формула в ячейке С 4 примет вид =С1+С2.
Если при копировании формул вы пожелаете сохранить ссылку на конкретную ячейку или область, то вам необходимо воспользоваться абсолютной адресацией. Для ее задания необходимо перед именем столбца и перед номером строки ввести символ $. Например: $В$4 или $C$2:$F$48 и т. д.
Смешанная адресация. Символ $ ставится только там, где он необходим. Например: В$4 или $С2. Тогда при копировании один параметр адреса изменяется. а другой — нет.
Объяснение:
При обращении к ячейке можно использовать описанные ранее ВЗ, А1:G9 и т. д. Такая адресация называется относительной. При ее использовании в формулахExcelзапоминает расположение относительно текущей ячейки. Так, например, когда вы вводите формулу =B1+B2 в ячейку В4, тоExcelинтерпретирует формулу как "прибавить содержимое ячейки, расположенной тремя рядами выше, к содержимому ячейки, расположенной двумя рядами выше".
Если вы скопировали формулу =В1+В2 из ячейки В4 в С4, Excelтакже интерпретирует формулу как «прибавить содержимое ячейки, расположенной тремя рядами выше, к содержимому ячейки двумя рядами выше». Таким образом, формула в ячейке С 4 примет вид =С1+С2.
Если при копировании формул вы пожелаете сохранить ссылку на конкретную ячейку или область, то вам необходимо воспользоваться абсолютной адресацией. Для ее задания необходимо перед именем столбца и перед номером строки ввести символ $. Например: $В$4 или $C$2:$F$48 и т. д.
Смешанная адресация. Символ $ ставится только там, где он необходим. Например: В$4 или $С2. Тогда при копировании один параметр адреса изменяется. а другой — нет.
ответ:Program z1;
var k : integer;
begin
writeln('Введіть номер місяця');
readln(k);
case k of 1: writeln('січень');
2: writeln('лютий');
3: writeln('березень');
4: writeln('квітень');
5: writeln('травень');
6: writeln('червень');
7: writeln('липень');
8: writeln('серпень');
9: writeln('вересень');
10: writeln('жовтень');
11: writeln('листопад');
12: writeln('грудень');
end; { case }
case k of 1,2,12: writeln('зима');
3,4,5: writeln('весна');
6,7,8: writeln('літо');
9,10,11: writeln('осінь');
else writeln('такого місяця немає');
end; { case }
readln end.
Объяснение: