В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
magicufoshowp08hm1
magicufoshowp08hm1
26.03.2023 07:46 •  Информатика

, очень надо. Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 7 и оканчивающихся на 1. Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). Введенные числа не превышают 300. Программа должна вывести одно число: сумму всех чисел, подходящих по условию.

кто-нибудь, умоляю 20б паскаль

Показать ответ
Ответ:
AndreyPulik
AndreyPulik
28.04.2021 23:50

var

sum,chislo:integer;

begin

while true do

begin

readln(chislo);

if chislo=0 then break;

if (chislo mod 7=0) and (chislo mod 10 = 1) then

sum+=chislo;

end;

writeln(sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота