В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
2001maks44
2001maks44
19.05.2020 05:51 •  Информатика

очень Напишите программу на языке Паскаль для решения задачи:
1. Запросить от пользователя трехзначное натуральное число.
2. Разбить число на цифры.
3. Найти сумму и произведение цифр числа.
4. Вывести на экран ответ "Больше", если сумма больше произведения,
ответ "Меньше" , если сумма меньше произведения
и "Равно", если сумма равна произведению.

Показать ответ
Ответ:
NoName353647
NoName353647
04.02.2021 16:10

var a,c1,c2,c3,p,s:integer;

begin

 p:=1;

 read(a);

 c1:=a mod 10;

 a:= a div 10;

 c2:=a mod 10;

 a:= a div 10;

  c2:=a mod 10;

  p:=c1*c2*c3;

  s:=c1+c2+c3;

  if s>p then writeln('больше') else if   s<p then writeln('меньше') else writeln('равно')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота