В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
faire6
faire6
16.01.2020 18:02 •  Информатика

Очень Напишите программу подсчета количества положительных, количества нулевых и количества отрицательных элементов массива. Проверьте работу программы на заданном массиве А = {7, 25, 4.5, 0, 17, 61, -10, 0, 1, -4, 22}.

Кол-во полож. элементов:

Кол-во нулевых элементов:

Кол-во отриц. элементов:

Показать ответ
Ответ:
Кологривко
Кологривко
15.10.2020 00:41

var

 a:array [1..11] of real;

 i,s1,s2:integer;

begin

 s1:=0; s2:=0;

 for i:=1 to 11 do

   begin

     readln(a[i]);

     if a[i]>0 then

       inc(s1)

         else

           if a[i]<0 then

             inc(s2);

   end;

 writeln('<0: ', s2);

 writeln('>0: ', s1);

 writeln('=0: ', i-s1-s2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота