В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
333399
333399
18.05.2021 22:38 •  Информатика

очень Составьте программу, выясняющую, есть ли в двухмерном массиве C(P,Q) строка, элементы которой образуют геометрическую прогрессию

Показать ответ
Ответ:
05багира
05багира
25.01.2021 21:57
C#
3:
using System.IO;
using System;

namespace тылпыа
{
    class Program
    {
        public static void Main(string[] args)
        {
            StreamReader reader = new StreamReader("input.txt");
            StreamWriter writer = new StreamWriter("output.txt");
            string input = " ";
            while (true) {
                input = reader.ReadLine();
                if (input == null) {
                    break;
                }
                writer.WriteLine(input.Replace(", короче,", ", в общем,"));
            }
            writer.Close();
        }
    }
}
0,0(0 оценок)
Ответ:
italyyyy
italyyyy
29.03.2023 08:25
Const N = 30; // Количетсво дней
var
i,count:integer;
h: array [1..N] of integer;
begin
count:=0;
writeln('Введите количество осадков');
for i:=1 to N do
read(h[i]);
for i:=1 to N do
if h[i]>0 then
count:=count+1;
writeln('Количество дождливых дней ', count)
end.

В первой строке указываем количество дней. Это константа N
Далее объявляем, что переменная count равна 0. В этой переменной мы будем хранить количество дней с осадками.
Далее мы вводим с клавиатуры 30 чисел, показывающих осадки.
Потом мы проверяем, если число в массиве больше нуля, то мы увеличиваем count на единицу. Тоесть прибавляем +1 день с осадками.
В конце выводим количество дней с осадками
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота