В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
flagvamvruke
flagvamvruke
29.04.2020 20:21 •  Информатика

Очень Задачи необходимо написать на языке Паскаль….

2.9. Три шахматиста играют в шахматы. Известно количество очков, набранных каждым из них. Составить программу, которая определит, на сколько очков победитель оторвался от самого слабого игрока.

3.10. На склад поступают груза на машинах различной грузоподъемности. Одновременно на компьютер, обслуживающий склад, поступает информация о весе груза на каждой машине. Составить программу, определяющую количество машин, прибывших с грузом до полного заполнения склада, если известно, что склад вмещает 1000 тонн груза.

Показать ответ
Ответ:
msajkina
msajkina
16.08.2021 13:30

В 2.9 нужно, как я понял, просто вычесть из кол-ва очков победителя кол-во очков самого слабого игрока.

В 3.10 - не совсем понятно как получаем данные. Вводятся вручную или уже загружены заранее? В любом случае можно сделать через цикл (для простоты напишу на питоне программу с ручным заполнением):

i = 0

while i < 1000:

   a = int(input())

   i += a

   print("Склад заполнен на ", i / 1000 * 100, "% (", i, ")")   #опционально

P.S. Паскаль не помню, извини.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота