В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
helgagrantt
helgagrantt
24.08.2022 17:33 •  Информатика

Одномерные массивы! На языке Python! Дано дробное число в двоичной системе счисления, т.е. последовательность цифр 0 и 1, разделенных точкой. Составить программу перевода
этого числа в восьмеричную систему счисления. ​

Показать ответ
Ответ:
Аминишка
Аминишка
12.12.2022 09:10
Program pr;
uses crt; 
Var a,b,c:integer; 

Begin   
Write('Введите 1-ю сторону: '); Readln(a);   
Write('Введите 2-ю сторону: '); Readln(b);   
Write('Введите 3-ю сторону: '); Readln(c); 
  
{Проверка на существование треугольника} 
if ((a+b)>c) and ((a+c)>b) and ((b+c)>a)   then        
     Begin                     
          if ((a=b)or (b=c) or (a=c)) then               
                Writeln('Треугольник равнобедренный');                       
 
         if ((a=b) and (b=c)) then               
            Writeln('Треугольник равносторонний')                 
         else Writeln('Треугольник разносторонний');           
  
        if ((a*a+b*b = c*c) or (a*a+c*c = b*b) or (b*b+c*c = a*a))    then
             Writeln('Треугольник прямоугольный');                      
    end   
   else       Writeln('Треугольник нельзя построить');    

Readln(); 
END.
0,0(0 оценок)
Ответ:
АлинаЛог
АлинаЛог
27.04.2022 20:32

Плагиа́т — умышленно совершаемое физическим лицом незаконное использование или распоряжение охраняемыми результатами чужого творческого труда, которое сопровождается доведением до других лиц ложных сведений о себе как о действительном авторе.

А́вторское пра́во — в объективном смысле — институт гражданского права, регулирующий правоотношения, связанные с созданием и использованием (изданием, исполнением, показом и т. д.) произведений науки, литературы или искусства, то есть объективных результатов творческой деятельности людей в этих областях.

Однако в литературе есть такое явление: "Пойман - не вор". Или "Этот плагиат - кого надо плагиат".

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота